WordPress中文论坛 - WordPress Chinese Forums

 找回密码
 注册
查看: 1471|回复: 3

dux 1.3 主题不支持php5.4以下的版本,怎么破?

[复制链接]

12

主题

122

帖子

409

金钱

WP 老手

Rank: 3Rank: 3Rank: 3

积分
401
发表于 2015-9-29 21:25:32 | 显示全部楼层 |阅读模式
本地测试dux1.3主题,发现在php5.3下报错:
Parse error: syntax error, unexpected '[' in E:\phpStudy\WWW\wp-content\themes\dux\footer.php on line 29
将php版本切换为5.4则不会出现这个问题,看了一下footer.php的代码,发现稍有不同,但是我不懂php,不知道如何修改,请问各位大神,怎样才能让dux1.3主题用于php5.4以下的版本?


http://www.gaohaipeng.com

9

主题

127

帖子

533

金钱

WP 老手

Rank: 3Rank: 3Rank: 3

积分
471
发表于 2015-10-2 12:47:39 | 显示全部楼层
用1.2的替换1.3的FOOTER.PHP

评分

参与人数 1金钱 +20 收起 理由
bbon + 20 鼓励,赞一个!

查看全部评分

12

主题

122

帖子

409

金钱

WP 老手

Rank: 3Rank: 3Rank: 3

积分
401
 楼主| 发表于 2015-10-6 17:28:55 | 显示全部楼层
dragonner 发表于 2015-10-2 12:47
用1.2的替换1.3的FOOTER.PHP

感谢指导。我注释掉那一行之后也可以,用1.2版本的替换也行。当然最好还是用5.4以上的PHP。
http://www.gaohaipeng.com

1

主题

7

帖子

20

金钱

WP 熟手

Rank: 2Rank: 2

积分
44
发表于 2015-10-24 10:27:44 | 显示全部楼层
路过路过路过路过路过路过路过路过路过
您需要登录后才可以回帖 登录 | 注册

本版积分规则

Archiver|手机版|小黑屋|联系我们|WordPress中文论坛 - CNWP ( 闽ICP备12016335号-11 )

GMT+8, 2020-7-14 14:58 , Processed in 0.093984 second(s), 30 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表